Attention is currently required from: daniel, laforge, pespin.
lynxis lazus has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007?usp=email )
Change subject: TCAP: Refactoring unroutable messages into own function ......................................................................
Patch Set 2:
(4 comments)
File src/tcap_as_loadshare.c:
https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/87db6544_c09cce... : PS2, Line 458: the message will be paths.
what do you mean by "the message will be paths"? I don't understand what this is supposed to say.
Done
https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/445464c7_6fc8ed... : PS2, Line 466: static int asp_loadshare_tcap_unroutable(struct osmo_ss7_asp **rasp,
asp_loadshare_tcap_unroutable_fallback() may be more descriptive. […]
fallback will be used by the DPC routing. I've renamed it to asp_loadshare_tcap_handle_unroutable
https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/c03bd5cf_e54137... : PS2, Line 608: rate_ctr_inc2(as->ctrg, SS7_AS_CTR_TCAP_ASP_FALLBACK);
AFAIU this patch could be reduce to only adding the following line here: […]
no, because you also have to set the rc code. In general this function needs to be refactored. it is far to long and complex.
I've refactored some of the parts. But still this function would need a refactoring
https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/9aa931d1_c8ed94... : PS2, Line 636: rate_ctr_inc2(as->ctrg, SS7_AS_CTR_TCAP_ASP_FALLBACK);
AFAIU this patch could be reduce to only adding the following line here: […]
see above.