Attention is currently required from: daniel, laforge, pespin.
4 comments:
File src/tcap_as_loadshare.c:
Patch Set #2, Line 458: the message will be paths.
what do you mean by "the message will be paths"? I don't understand what this is supposed to say.
Done
Patch Set #2, Line 466: static int asp_loadshare_tcap_unroutable(struct osmo_ss7_asp **rasp,
asp_loadshare_tcap_unroutable_fallback() may be more descriptive. […]
fallback will be used by the DPC routing. I've renamed it to asp_loadshare_tcap_handle_unroutable
Patch Set #2, Line 608: rate_ctr_inc2(as->ctrg, SS7_AS_CTR_TCAP_ASP_FALLBACK);
AFAIU this patch could be reduce to only adding the following line here: […]
no, because you also have to set the rc code. In general this function needs to be refactored. it is far to long and complex.
I've refactored some of the parts. But still this function would need a refactoring
Patch Set #2, Line 636: rate_ctr_inc2(as->ctrg, SS7_AS_CTR_TCAP_ASP_FALLBACK);
AFAIU this patch could be reduce to only adding the following line here: […]
see above.
To view, visit change 43007. To unsubscribe, or for help writing mail filters, visit settings.