Attention is currently required from: jolly, lynxis lazus. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/35567?usp=email ) Change subject: VTY: Add command `show bts online` ...................................................................... Patch Set 1: (2 comments) File src/osmo-bsc/bsc_vty.c: https://gerrit.osmocom.org/c/osmo-bsc/+/35567/comment/893773ba_ff87bb28 PS1, Line 262: Display availability status of all BTS `online` in the command name suggests that the command is supposed to show only those BTS instances, which are online. However, it's actually more like `brief`. https://gerrit.osmocom.org/c/osmo-bsc/+/35567/comment/3c2438f5_47eee87a PS1, Line 268: for (bts_nr = 0; bts_nr < net->num_bts; bts_nr++) Not a performance critical path, but I would still suggest doing this: ``` llist_for_each_entry(bts, &net->bts_list, list) ``` instead. This is what `gsm_bts_num()` does internally. The problem with the current approach is that the higher `bts_nr` you pass it, the more iterations it takes to find the BTS instance. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/35567?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I003fd32e589ddf53b7dd42089f904cfb598e3625 Gerrit-Change-Number: 35567 Gerrit-PatchSet: 1 Gerrit-Owner: jolly <andreas@eversberg.eu> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: lynxis lazus <lynxis@fe80.eu> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-CC: fixeria <vyanitskiy@sysmocom.de> Gerrit-Attention: jolly <andreas@eversberg.eu> Gerrit-Attention: lynxis lazus <lynxis@fe80.eu> Gerrit-Comment-Date: Mon, 15 Jan 2024 18:27:47 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment