Hi all, for a bit of bikeshed fun on the side, I'd like to ask your opinions on a good name. The background: we're in the process of separating libmsc from libbsc. Both use the structs gsm_network and gsm_subscriber_connection, and both of these structs contain elements that are used only by libbsc or only by libmsc, besides the elements that are used by both. So at some point I will "split" both of these in two, to have a BSC and an MSC version thereof. How should we name them? struct gsm_network (note, if there is a common part, that could still be named 'gsm_network') --> bsc_network / msc_network looks familiar but the meaning of the name is lost --> gsm_bsc / gsm_msc --> osmo_bsc / osmo_msc To me these would be the best and the names are still available, but there are header files named like this and the osmo-bsc binary also has a very similar name. I think I would go for these anyway. +1 --> osmo_gsm_bsc / osmo_gsm_msc As alternative, but the gsm is a bit out of place (particularly in the light of a UMTS MSC). struct gsm_subscriber_connection --> bsc_subscriber_connection / msc_subscriber_connection but we could use the opportunity to shorten the name --> bsc_subscr_conn / msc_subscr_conn I like these best; but add osmo? +1 --> osmo_bsc_subscr_conn / osmo_msc_subscr_conn almost the old length. Happy shedding, "+1" comments and/or opinions welcome ~Neels -- - Neels Hofmeyr <nhofmeyr@sysmocom.de> http://www.sysmocom.de/ ======================================================================= * sysmocom - systems for mobile communications GmbH * Alt-Moabit 93 * 10559 Berlin, Germany * Sitz / Registered office: Berlin, HRB 134158 B * Geschäftsführer / Managing Directors: Harald Welte