[M] Change in osmo-upf[master]: Validate session remote CP F-SEID and use it to transmit session requ...
Attention is currently required from: neels, pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-upf/+/41482?usp=email ) Change subject: Validate session remote CP F-SEID and use it to transmit session requests ...................................................................... Patch Set 1: (3 comments) File src/osmo-upf/up_endpoint.c: https://gerrit.osmocom.org/c/osmo-upf/+/41482/comment/89c29d8b_ac966511?usp=... : PS1, Line 176: OSMO_ASSERT(f_seid) missing semicolon? https://gerrit.osmocom.org/c/osmo-upf/+/41482/comment/44410d52_347faa68?usp=... : PS1, Line 217: nack_response I would go for a separate function (e.g. `up_ep_tx_nack()`) to avoid code duplication. File src/osmo-upf/up_session.c: https://gerrit.osmocom.org/c/osmo-upf/+/41482/comment/c5055d00_e4a50b9f?usp=... : PS1, Line 115: return NULL; This code is unreachable. Maybe do `OSMO_ASSERT(0)` here and remove these two above? -- To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/41482?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-upf Gerrit-Branch: master Gerrit-Change-Id: Ifccd4d2b8d500c9928778400bb096baaa12c9a31 Gerrit-Change-Number: 41482 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy@sysmocom.de> Gerrit-Reviewer: laforge <laforge@osmocom.org> Gerrit-Reviewer: neels <nhofmeyr@sysmocom.de> Gerrit-Reviewer: osmith <osmith@sysmocom.de> Gerrit-Attention: neels <nhofmeyr@sysmocom.de> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Comment-Date: Mon, 01 Dec 2025 11:54:44 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
participants (1)
-
fixeria