[S] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
Attention is currently required from: arehbein, daniel, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 2: (1 comment) File include/osmocom/core/gsmtap_util.h: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/f2bed0d0_97a59349 PS2, Line 30:
I think this would allow us to keep `gsmtap_inst_fd()` as `static inline` inside the header, without […] No, better move it to a function like you did here. Already compiled code will already have the implementation compiled in its code, but at least for new code we now control the implementation in the lib.
The point of having gsmtap_inst_fd2() as separate of gsmtap_inst_fd2(), is that we can mark the former as DEPRECATED and force everybody to update to gsmtap_inst_fd2() at some point, meaning we know for sure all users will end up using the non-static-inline version. So the change of static inline to a full function can be tracked more easily and more clearly. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 2 Gerrit-Owner: arehbein <arehbein@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann@sysmocom.de> Gerrit-Reviewer: laforge <laforge@osmocom.org> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: arehbein <arehbein@sysmocom.de> Gerrit-Attention: laforge <laforge@osmocom.org> Gerrit-Attention: daniel <dwillmann@sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 13:42:33 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: arehbein <arehbein@sysmocom.de> Comment-In-Reply-To: pespin <pespin@sysmocom.de> Gerrit-MessageType: comment
participants (1)
-
pespin