Attention is currently required from: fixeria. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/35553?usp=email ) Change subject: global_platform: Implement generic store_data command ...................................................................... Patch Set 1: (2 comments) File pySim/global_platform.py: https://gerrit.osmocom.org/c/pysim/+/35553/comment/a545e02d_86f9431e PS1, Line 344: opts.response == 'may_be_returned'
The operator `==` already gives `True/False`, so ternary operator is redundant. Ack
https://gerrit.osmocom.org/c/pysim/+/35553/comment/2e610e9f_1a71c14e PS1, Line 361: sw
Do we want to check `sw` here? the method send_apdu_checksw() already does that check internally, as the name implies. It will raise an exception if it's not a succesful SW.
-- To view, visit https://gerrit.osmocom.org/c/pysim/+/35553?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: If30c5d31b4e7dd60d3a5cfb1d1cbdcf61741a50e Gerrit-Change-Number: 35553 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge@osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy@sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy@sysmocom.de> Gerrit-Comment-Date: Fri, 12 Jan 2024 10:52:01 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy@sysmocom.de> Gerrit-MessageType: comment