pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33523 ) Change subject: stream: Rename static function to have correct prefix ...................................................................... stream: Rename static function to have correct prefix That function is used by the srv_link object, not the srv object. Rename it to avoid confusion. Change-Id: I1a3870b3a269b84ac2a9285ee6fe3389c5c96a94 --- M src/stream.c 1 file changed, 14 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-netif refs/changes/23/33523/1 diff --git a/src/stream.c b/src/stream.c index fdc1cc1..f007cc4 100644 --- a/src/stream.c +++ b/src/stream.c @@ -1151,7 +1151,7 @@ int flags; }; -static int osmo_stream_srv_ofd_cb(struct osmo_fd *ofd, unsigned int what) +static int osmo_stream_srv_link_ofd_cb(struct osmo_fd *ofd, unsigned int what) { int ret; int sock_fd; @@ -1227,7 +1227,7 @@ link->sk_domain = AF_UNSPEC; link->sk_type = SOCK_STREAM; link->proto = IPPROTO_TCP; - osmo_fd_setup(&link->ofd, -1, OSMO_FD_READ | OSMO_FD_WRITE, osmo_stream_srv_ofd_cb, link, 0); + osmo_fd_setup(&link->ofd, -1, OSMO_FD_READ | OSMO_FD_WRITE, osmo_stream_srv_link_ofd_cb, link, 0); return link; } -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33523 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I1a3870b3a269b84ac2a9285ee6fe3389c5c96a94 Gerrit-Change-Number: 33523 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin@sysmocom.de> Gerrit-MessageType: newchange