Attention is currently required from: pespin. jolly has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/libosmocore/+/40494?usp=email ) Change subject: Send multiple read/recvfrom/recvmsg SQEs in advance ...................................................................... Patch Set 9: (3 comments) File src/core/osmo_io_internal.h: https://gerrit.osmocom.org/c/libosmocore/+/40494/comment/2ab53459_c27a4029?u... : PS8, Line 113: uint8_t read_sqes;
num_read_sqes? Done
https://gerrit.osmocom.org/c/libosmocore/+/40494/comment/6711bad0_1c5335b6?u... : PS8, Line 117: uint8_t read_count;
reads_in_transit? reads_in_progress? Done
File src/core/osmo_io_uring.c: https://gerrit.osmocom.org/c/libosmocore/+/40494/comment/f81052ad_e3d47ddf?u... : PS8, Line 152: msg = iofd_msgb_alloc(iofd);
I think having each loop iteration in a separate function should make this easier to read and mainta […] Done
-- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/40494?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Id50a8900fa2fe6de553e5025feae7e1e8d501e30 Gerrit-Change-Number: 40494 Gerrit-PatchSet: 9 Gerrit-Owner: jolly <andreas@eversberg.eu> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Comment-Date: Tue, 29 Jul 2025 10:38:45 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin@sysmocom.de>