Attention is currently required from: laforge, pespin. jolly has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/libosmocore/+/40725?usp=email ) Change subject: Automatically increase io_uring, if too small. ...................................................................... Patch Set 4: (6 comments) File src/core/osmo_io_internal.h: https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/88d1e846_2dae4314?u... : PS2, Line 110: void *read_ring[IOFD_MSGHDR_READ_SQES];
some comments here would be useful to explan what those fields are and how hey are used (not just th […] Done
File src/core/osmo_io_uring.c: https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/71b86426_f122d2f5?u... : PS2, Line 67: g_io_uring_queue
pleaes use a more descriptive name. The variable is not a qeuue, but it is the size of the ring. […] Done
https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/e38bd57a_d54e1f06?u... : PS2, Line 113: OSMO_IO_URING_QUEUE
like the variable name in the code, the environment variable name shold be self-descriptive. […] Done
https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/720762d0_8db9c7c1?u... : PS2, Line 163: osmo_iofd_uring_get_sqe
the 'osmo_' prefix is reserverd for exported functions. […] Done
https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/86884b81_0162c7d1?u... : PS2, Line 172: LOGP(DLIO, LOGL_NOTICE, "io_uring too small to handle all SQEs, increasing size to %d.\n", g_io_uring_queue);
minor: while the current implementation alsways doubles the size, it might still be useful to print […] Done
https://gerrit.osmocom.org/c/libosmocore/+/40725/comment/13d47890_d1b52789?u... : PS2, Line 175:
is there code to clean up the old ring after completion of the last cqe of the old ring? No, it doesn't, because I don't track the number of submissions and the number of completions. I could do that. This would make it more complex, especially during cancellation process. I can add this if you want and test with the ttcn3 tests.
-- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/40725?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Id9230146acc8d54bfd44834e783c31b37bd64bca Gerrit-Change-Number: 40725 Gerrit-PatchSet: 4 Gerrit-Owner: jolly <andreas@eversberg.eu> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge@osmocom.org> Gerrit-CC: pespin <pespin@sysmocom.de> Gerrit-Attention: laforge <laforge@osmocom.org> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Comment-Date: Mon, 28 Jul 2025 10:19:39 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge@osmocom.org>