openggsn fails on debian 8

Kasper Nielsen kasp.niel at gmail.com
Wed Jun 3 17:33:33 UTC 2015


after apt-get install libtool the errors was removed. but I cannot run make.
it says "No targets specified and no makefile found" stop.

On Wed, Jun 3, 2015 at 6:24 PM, Kasper Nielsen <kasp.niel at gmail.com> wrote:

> alcohol was a typo from my operating system.
>
> when running autoreconf -i I get this:
>
> autoreconf -i
> aclocal: warning: autoconf input should be named 'configure.ac', not '
> configure.in'
> aclocal: warning: couldn't open directory 'm4': No such file or directory
> automake: warning: autoconf input should be named 'configure.ac', not '
> configure.in'
> configure.in:13: installing './compile'
> configure.in:7: installing './config.guess'
> configure.in:7: installing './config.sub'
> configure.in:14: installing './install-sh'
> configure.in:105: installing './missing'
> Makefile.am: installing './INSTALL'
> automake: warning: autoconf input should be named 'configure.ac', not '
> configure.in'
> ggsn/Makefile.am: installing './depcomp'
> gtp/Makefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
> gtp/Makefile.am:1:   The usual way to define 'LIBTOOL' is to add 'LT_INIT'
> gtp/Makefile.am:1:   to 'configure.in' and run 'aclocal' and 'autoconf'
> again.
> gtp/Makefile.am:1:   If 'LT_INIT' is in 'configure.in', make sure
> gtp/Makefile.am:1:   its definition is in aclocal's search path.
> lib/Makefile.am:1: error: library used but 'RANLIB' is undefined
> lib/Makefile.am:1:   The usual way to define 'RANLIB' is to add
> 'AC_PROG_RANLIB'
> lib/Makefile.am:1:   to 'configure.in' and run 'autoconf' again.
> autoreconf: automake failed with exit status: 1
>
>
> On Wed, Jun 3, 2015 at 4:51 PM, Alexander Huemer <alexander.huemer at xx.vu>
> wrote:
>
>> Hi.
>>
>> On Wed, Jun 03, 2015 at 04:22:32PM +0200, Kasper Nielsen wrote:
>> > when trying to install on clean debian 8 I get errors.
>> >
>> > This is my bash:
>> > ./configure
>> > bash: ./configure: No such file or directory
>> >
>> > running alcohol && automake && autoheader && autoconf also gives lots of
>> > errors.
>>
>> What's alcohol?
>>
>> autoreconf -i produces a configure script just fine on my jessie/amd64
>> installation. There is only a minor warning regarding configure.{in,ac}.
>> configure does not complain either.
>> make produces some -Wformat warnings, nothing scary.
>> openggsn does not seem to be broken at all.
>>
>> Kind regards,
>> -Alex
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-net-gprs/attachments/20150603/6e5b3855/attachment.html>


More information about the osmocom-net-gprs mailing list