GSMTAP messages not generated

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at

Mario Lucas mariolucas75 at
Thu Oct 28 15:11:17 UTC 2021

Dear All,
I am running a GSM stack:
It seems that my transmitter is emitting radio-waves into air (osmo-bts-trx and osmo-trx-lms communicate with each other through ports 5702 / 5802 — pls see attached printscreen), however i could not make GSMTAP tracing. Osmo-bts-trx does not send GSMTAP messages to port 4729.
In most recent version of osmo-bts, GSMTAP tracing is arranged through config file:
bts 0
  gsmtap-sapi ccch
I could not run the GSMTAP tracing even in previous verions of osmo-bts where you have to specify in synopsis when you call a program:
/usr/bin/osmo-bts-trx -s -c /etc/osmocom/osmo-bts-trx.cfg --gsmtap-ip
I thought may be i am having some issues in stack components behind osmo-bts for example in osmo-bsc or behind and i tried to run virtual bts.
When i tried to run osmo-bts-virtual GSMTAP messages were visible in wireshark (please see attached file osmo-bts-virtual), therefore bts-bsc communication is good.
However I still could not figure out why my osmo-bts-trx does not send GSMTAP messages.
Or would you advise what log might be helpful to see what i am doing wrong ….
Thank you for your always helpful assistance
Mario Lucas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: osmo-bts-trx.jpg
Type: image/jpeg
Size: 125776 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: osmo-bts-virtual.jpg
Type: image/jpeg
Size: 118948 bytes
Desc: not available
URL: <>

More information about the baseband-devel mailing list