Help on building the OpenBTS / OsmoBTS Transceiver branch

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at

Craig Comstock craig at
Thu Jul 22 02:59:02 UTC 2021

I tried the instructions here:

on a pretty clean and up to date Debian 10 vm and had no problems.

I used the arm-none-eabi-* packages that come with Debian.

arm-none-eabi-gcc --version
arm-none-eabi-gcc (15:7-2018-q2-6) 7.3.1 20180622 (release) [ARM/embedded-7-branch revision 261907]

Maybe you need to do some steps like

$ sudo make uninstall
$ make distclean
$ git pull --rebase
In libosmocore and libosmo-dsp?

I used the fixeria/trx branch as mentioned in the wiki page above.


> On Jul 21, 2021, at 5:42 PM, . <meursault at> wrote:
> Hello,
> I'm trying to build the transceiver branch for Calypso phones. I
> installed all OsmocomBB dependencies (including libosmocore) and i
> sucessfully built and installed libosmo-dsp from the Git repo. My ARM
> toolchain is from here:
> .
> When building, however, the compiler fails with:
> arm-none-eabi-ld:
> comm/libcomm.a(msgb.o):~/trx/src/target/firmware/comm/msgb.c:35:
> multiple definition of
> `tall_msgb_ctx'; ../../shared/libosmocore/build-target/src/.libs/libosmocore.a(msgb.o):(.bss+0x0):
> first defined here recipe for target
> 'board/compal_e88/hello_world.highram.elf' failed
> I tried both sylvain/testing and jolly/testing branches.
> What seems to be the problem?
> Thanks!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the baseband-devel mailing list