osmocom-bb compilation problems

Nikos Balkanas nbalkanas at gmail.com
Sun May 13 18:28:57 UTC 2018


Hi Sylvain,

I didn't realize it when you responded, but <sys/_types.h> is a toolchain
problem, and you just nailed it.
Cool:)

Early on, before it was pointed to me to use the Getting Started wiki, I
used the src/README.building file,
which is a normal practice for all unix developers/admins. When I couldn't
find the gnuarm.com toolchain, I searched the web
for ubuntu toolchains and found the linaro one, gcc-arm-linux-gnueabi,
which doesn't provide <sys_types.h>.
No dev version either:(
So, when using that toolchain, I had to come up with the missing
<sys/_types.h>, and the only one I could find
was from vivado:(

Is there a point to my life's story? Just to pont out into how much
problems one can get with the wrong README file.
I realize that building procedure must be defined and maintained in 1
place, either the wiki or the README file.
The wiki is a non standard unix location, but a more convenient one. I
propose to fix the info in README.building,
to avoid future issues. The fix can be as simple as "Prerequisite is the
armel toolchain. Check the <wiki url> for installation"

HTH
Nikos

On Sun, May 13, 2018 at 12:11 PM, Nikos Balkanas <nbalkanas at gmail.com>
wrote:

> Thx Sylvain,
>
> For your fast response.
> This turned out not to be the problem, since I did several times make
> clean & make distclean, after I created the toolchain, before posting:)
> But your response helped, in that this isn't a usual problem. Therefore
> smt in my setup.
>
> Turned out problem was in my CPPFLAGS include dir.
> Early on, I faced a few problems with missing include files. 1 in
> particular <sys/_types.h> was nowhere in my system other than in Xilinx
> vivado,
> under /gcc-arm-none-eabi/.
> Once I removed it from CPPFLAGS osmocom-bb compiled fine (with a few
> warnings)
>
> Problem solved:)
>
>
> On Sun, May 13, 2018 at 10:15 AM, Sylvain Munaut <246tnt at gmail.com> wrote:
>
>> > I've been following the installation directions from the wiki, Getting
>> > Started.
>> > After generating the arm-none-eabi toolchain, I proceeded with make.
>>
>> My guess is you first tried compiling without an arm toolchain
>> installed and then installed the arm toolchain and didn't do a 'make
>> clean' when retrying.
>>
>>
>> Cheers,
>>
>>    Sylvain
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20180513/2358cc0c/attachment.html>


More information about the baseband-devel mailing list