osmocom-bb compilation problems

Nikos Balkanas nbalkanas at gmail.com
Sun May 13 09:11:18 UTC 2018


Thx Sylvain,

For your fast response.
This turned out not to be the problem, since I did several times make clean
& make distclean, after I created the toolchain, before posting:)
But your response helped, in that this isn't a usual problem. Therefore smt
in my setup.

Turned out problem was in my CPPFLAGS include dir.
Early on, I faced a few problems with missing include files. 1 in
particular <sys/_types.h> was nowhere in my system other than in Xilinx
vivado,
under /gcc-arm-none-eabi/.
Once I removed it from CPPFLAGS osmocom-bb compiled fine (with a few
warnings)

Problem solved:)


On Sun, May 13, 2018 at 10:15 AM, Sylvain Munaut <246tnt at gmail.com> wrote:

> > I've been following the installation directions from the wiki, Getting
> > Started.
> > After generating the arm-none-eabi toolchain, I proceeded with make.
>
> My guess is you first tried compiling without an arm toolchain
> installed and then installed the arm toolchain and didn't do a 'make
> clean' when retrying.
>
>
> Cheers,
>
>    Sylvain
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20180513/f9922370/attachment.html>


More information about the baseband-devel mailing list