Sylvain testing branch

R M rm.engineer84 at gmail.com
Fri May 23 12:07:29 UTC 2014


Hi,

Thanks Sylvain.

> The doc on the wiki and the README.building in the tree specifically
> says you need to install libosmocore from the GIT and _NOT_ the one
> embedded in the tree. The one in the tree is a special version for the
> ARM code and must NOT be used on the host.
>
> You must not go and muck around with the build system. Just doing make
> in the src/ dir should be all you need to

Initially I did not realize that. But then I got it. The problem being
that around 2011, I had downloaded the code and at that time we did
not have to download the libosmocore separately.

Now things are different.

I built it as per instructions but still the phone was not able to
sync to any channel. First I thought that the problem could be because
that the battery loop was causing the issue. So I changed the battery
loop to report status every 5 min. But still no luck.

Then I thought may be the tool chain is the problem. So, to test this,
I compiled the 2011 code with my tool chain and it also did not sync
to any channel while previously it had worked.

So I have left the new code for the time being. I am working on an
older code that works.

I will raise certain concerns that I have here:

 If there is a problem in the code in layer 1 that is downloaded to
the phone, I am not able to figure out what went wrong. The phone
doesn't seem to output any error like buffer overflow, packet dropped.
It just goes blank. I really don't know how you guys figure problems
out that have happened in layer 1 code.

To give an example:

When the phone wants to sync to a beacon channel which is supplied in
the command line, The upper layer tells the tuner to tune to that
particular frequency, the dsp tries to detect the Frequency correction
burst and then tries to correct the frequency error between the bts
and phone. Once the frequency sync, we need to sync in time (we need
to know the frame number)so it tries to detect the SYNC burst which
tells the frame number and other details.

If the above operation fails all we get is FSB 255 result and nothing
else. From this I don't know where I need to look. Do I need to look
at layer 1, upper layers, computer not fast enough to issue
appropriate commands in time, serial line congested, tool chain not
proper and code not aligned properly in phone etc.

Since there are so many reasons for the above failure, I don't know
how to eliminate each of these cases and proceed further.

Lets say the above problem is caused by  tool chain is not proper, how
can I be very sure that its the tool chain. Should I dump the layer 1
using obj dump and check what is there. in what location and compare
it with the memory map as given in the calypso programmer manual or
some other method needs to be followed.

I don't think you magically got the right tool chain the first time
through. You must have tried different tool chains, figured out the
error and then finally got the right tool-chain


Can you please share how you would trouble shoot issues of this kind ?
This would help me a lot as all I am doing here is trial and error and
this is not helping me in learning.

Regards,
RM




More information about the baseband-devel mailing list