libosmocore patch to support custom baud rates on OS X

Martin Auer catchall at blombo.de
Sun Oct 2 04:51:01 UTC 2011


Am 02.10.2011 um 06:01 schrieb Lukas Kuzmiak <lukash at backstep.net>:

> I can confirm this has fixed the error during the compilation, I've run into a different issue however, while building layer23 module(s) I get:
> 
> ./configure: line 3461: syntax error near unexpected token `LIBOSMOCORE,'
> ./configure: line 3461: `PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore)'
> make: *** [host/layer23/Makefile] Error 2
> 
> during the configure, anyone run into that issue?
> 

This is an error I had when my PATH Variable was not set correctly. For building on OSX I recently wrote a wiki entry:

http://bb.osmocom.org/trac/wiki/GettingStarted_osx

> Btw, are you using gcc-4.2 from XCode or you've got a separate build environment from some macports/fink/homebrew?

Ports and fink will do.
> 
> Thanks!
> Lukas
> 
> On Wed, Sep 28, 2011 at 8:31 AM, Martin Auer <catchall at blombo.de> wrote:
> 
> Am 28.09.2011 um 06:16 schrieb Richard James:
> 
> > This patch should allow custom baud-rate setting to work on OS X; tested
> > on Mac OS X 10.7 with a FT232BL-based adapter.
> >
> Thanks very much, that solved my problem reported some days ago.
> >
> >
> >
> > <set_custom_baudrate_osx.patch>
> 
> 
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20111002/4b2f0c53/attachment.html>


More information about the baseband-devel mailing list