[M] Change in libosmocore[master]: util: add osmo_strbuf macros to manipulate the strbuf tail
Attention is currently required from: neels. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/35207?usp=email ) Change subject: util: add osmo_strbuf macros to manipulate the strbuf tail ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File include/osmocom/core/utils.h: https://gerrit.osmocom.org/c/libosmocore/+/35207/comment/c3dba968_29edcd21 PS1, Line 329: } while (0) What is the advantage of having these long macros instead of turning them into (probably more readable) functions? -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35207?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I997707c328eab3ffa00a78fdb9a0a2cbe18404b4 Gerrit-Change-Number: 35207 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: osmith <osmith@sysmocom.de> Gerrit-Attention: neels <nhofmeyr@sysmocom.de> Gerrit-Comment-Date: Mon, 04 Dec 2023 08:23:53 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
participants (1)
-
osmith