[S] Change in libosmocore[master]: osmo_io: Clean up code
Attention is currently required from: arehbein, pespin. daniel has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34524?usp=email ) Change subject: osmo_io: Clean up code ...................................................................... Patch Set 1: (1 comment) Patchset: PS1:
Maybe extending the doc saying it should be called on each thread using the API would be welcome. In that case I think we should have a section named "threading" somewhere in the API docs and list the relevant functions.
From what I can tell there's at least: * osmo_ctx_init() * osmo_select_init() * osmo_iofd_init() which need to be initialized per thread and certain things that have to be used from the main thread. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34524?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I77f7ae2b211507f420d87c484ec75ee054fceb63 Gerrit-Change-Number: 34524 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann@sysmocom.de> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: arehbein <arehbein@sysmocom.de> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Comment-Date: Wed, 27 Sep 2023 15:34:31 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin@sysmocom.de> Comment-In-Reply-To: daniel <dwillmann@sysmocom.de> Gerrit-MessageType: comment
participants (1)
-
daniel