[M] Change in osmo-mgw[master]: vty and log: also show local port for RTP conns
Attention is currently required from: dexter, keith, osmith. neels has uploaded a new patch set (#3) to the change originally created by keith. ( https://gerrit.osmocom.org/c/osmo-mgw/+/34150?usp=email ) The following approvals got outdated and were removed: Verified+1 by Jenkins Builder Change subject: vty and log: also show local port for RTP conns ...................................................................... vty and log: also show local port for RTP conns Before: CONN: (1226/rtp, id:0xD94316AD, ip:127.0.0.2, rtp:2344 rtcp:2345) After: CONN: (1226/rtp C:D94316AD r=127.0.0.2:2344<->l=127.0.0.1:4002) While changing that string, also include these changes for consistency and readability: - use the same r:...<->l:... format as osmo_sock_get_name(). - Instead of 'id:0x' use the actual MGCP format 'C: 9B686BE3'. - drop the commas - drop RTCP port: it is always RTP+1 and always an odd number. Rationale: The CONN pairs associated with each endpoint show remote RTP ports. When osmo-mgw is being used by both BSC and MSC, one side of the pair is showing the internal loop connection inside osmo-mgw, while my intuition suggested this connection pair is showing me the RTP port tuple of a single RTP stream. Adding the local port to the display makes it more clear, IMHO. Seeing the local port can also help to correlate the MGW vty dump with a capture of RTP. Implementation: I first tried directly using osmo_sock_get_name_buf() on conn->u.rtp.end.rtp.fd, but that might hide already known information when the fd is not actively used yet (before SDP): the local address and port would then be shown from the fd, not from conn->u.rtp.end.local_addr/_port == hidden before the fd is set up. Patch-By: whytek, nhofmeyr Change-Id: Ib89a6779e1d68c6600f00699d4303f6c0ee07132 --- M src/libosmo-mgcp/mgcp_conn.c 1 file changed, 58 insertions(+), 30 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/50/34150/3 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/34150?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: Ib89a6779e1d68c6600f00699d4303f6c0ee07132 Gerrit-Change-Number: 34150 Gerrit-PatchSet: 3 Gerrit-Owner: keith <keith@rhizomatica.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier@sysmocom.de> Gerrit-Reviewer: osmith <osmith@sysmocom.de> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: osmith <osmith@sysmocom.de> Gerrit-Attention: keith <keith@rhizomatica.org> Gerrit-Attention: dexter <pmaier@sysmocom.de> Gerrit-MessageType: newpatchset
participants (1)
-
neels