[S] Change in ...osmo-epdg[master]: Rename s/ue_fsm/epdg_ue_fsm/g
pespin has submitted this change. ( https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/35686?usp=email ) Change subject: Rename s/ue_fsm/epdg_ue_fsm/g ...................................................................... Rename s/ue_fsm/epdg_ue_fsm/g osmo-epdg actually contains 2 nodes inside: ePDG and AAA server. The fsm is for the ePDG node, and ideally we want to keep both nodes as separate as possible so that we can later on split them or use an external AAA server. Change-Id: If0852f4aedd0fb0cb9bf6cfcf77f00acd4a3fcbf --- M src/epdg_gtpc_s2b.erl R src/epdg_ue_fsm.erl M src/gsup_server.erl 3 files changed, 23 insertions(+), 9 deletions(-) Approvals: pespin: Looks good to me, approved Jenkins Builder: Verified laforge: Looks good to me, but someone else must approve diff --git a/src/epdg_gtpc_s2b.erl b/src/epdg_gtpc_s2b.erl index 7e3dd6e..ca05d9b 100644 --- a/src/epdg_gtpc_s2b.erl +++ b/src/epdg_gtpc_s2b.erl @@ -287,7 +287,7 @@ Sess1 = update_gtp_session_from_create_session_response(Resp, Sess0), lager:info("s2b: Updated Session after create_session_response: ~p~n", [Sess1]), State1 = update_gtp_session(Sess0, Sess1, State0), - ue_fsm:received_gtpc_create_session_response(Sess0#gtp_session.pid, {ok, Resp}), + epdg_ue_fsm:received_gtpc_create_session_response(Sess0#gtp_session.pid, {ok, Resp}), {noreply, State1} end; @@ -299,7 +299,7 @@ {noreply, State0}; Sess -> State1 = delete_gtp_session(Sess, State0), - ue_fsm:received_gtpc_delete_session_response(Sess#gtp_session.pid, Resp), + epdg_ue_fsm:received_gtpc_delete_session_response(Sess#gtp_session.pid, Resp), {noreply, State1} end; diff --git a/src/ue_fsm.erl b/src/epdg_ue_fsm.erl similarity index 99% rename from src/ue_fsm.erl rename to src/epdg_ue_fsm.erl index f17dfdc..f8fca64 100644 --- a/src/ue_fsm.erl +++ b/src/epdg_ue_fsm.erl @@ -30,9 +30,9 @@ % for the parts of the runtime libraries of Erlang/OTP used as well as % that of the covered work. --module(ue_fsm). +-module(epdg_ue_fsm). -behaviour(gen_statem). --define(NAME, ue_fsm). +-define(NAME, epdg_ue_fsm). -include_lib("osmo_gsup/include/gsup_protocol.hrl"). -include_lib("gtplib/include/gtp_packet.hrl"). diff --git a/src/gsup_server.erl b/src/gsup_server.erl index cebcc0f..ae677c9 100644 --- a/src/gsup_server.erl +++ b/src/gsup_server.erl @@ -223,7 +223,7 @@ % send auth info / requesting authentication tuples handle_info({ipa, Socket, ?IPAC_PROTO_EXT_GSUP, _GsupMsgRx = #{message_type := send_auth_info_req, imsi := Imsi}}, State0) -> {UE, State1} = find_or_new_gsups_ue(Imsi, State0), - case ue_fsm:auth_request(UE#gsups_ue.pid) of + case epdg_ue_fsm:auth_request(UE#gsups_ue.pid) of ok -> ok; {error, _} -> Resp = #{message_type => send_auth_info_err, @@ -241,7 +241,7 @@ UE = find_gsups_ue_by_imsi(Imsi, State), case UE of #gsups_ue{imsi = Imsi} -> - case ue_fsm:lu_request(UE#gsups_ue.pid) of + case epdg_ue_fsm:lu_request(UE#gsups_ue.pid) of ok -> ok; {error, _} -> Resp = #{message_type => location_upd_err, @@ -268,7 +268,7 @@ UE = find_gsups_ue_by_imsi(Imsi, State), case UE of #gsups_ue{imsi = Imsi} -> - case ue_fsm:tunnel_request(UE#gsups_ue.pid) of + case epdg_ue_fsm:tunnel_request(UE#gsups_ue.pid) of ok -> ok; {error, _} -> Resp = #{message_type => epdg_tunnel_error, @@ -294,7 +294,7 @@ UE = find_gsups_ue_by_imsi(Imsi, State), case UE of #gsups_ue{imsi = Imsi} -> - case ue_fsm:purge_ms_request(UE#gsups_ue.pid) of + case epdg_ue_fsm:purge_ms_request(UE#gsups_ue.pid) of ok -> ok; _ -> Resp = #{message_type => purge_ms_err, imsi => Imsi, @@ -349,7 +349,7 @@ new_gsups_ue(Imsi, State) -> - {ok, Pid} = ue_fsm:start_link(Imsi), + {ok, Pid} = epdg_ue_fsm:start_link(Imsi), UE = #gsups_ue{imsi = Imsi, pid = Pid}, NewSt = State#gsups_state{ues = sets:add_element(UE, State#gsups_state.ues)}, {UE, NewSt}. -- To view, visit https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/35686?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: erlang/osmo-epdg Gerrit-Branch: master Gerrit-Change-Id: If0852f4aedd0fb0cb9bf6cfcf77f00acd4a3fcbf Gerrit-Change-Number: 35686 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge@osmocom.org> Gerrit-Reviewer: lynxis lazus <lynxis@fe80.eu> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-MessageType: merged
participants (1)
-
pespin