rtl-fm yet another audio cature problem

Olof Tangrot olof.tangrot at gmail.com
Sat Nov 17 14:18:18 UTC 2012


Hi.
I have tried (in a bash shell):
rtl_fm -f 96.3e6 -s 48000 - | aplay -r raw -f dat -c 1

That was proposed somewhere as an example to listen to an FM station. But
everything terminates with:
aplay: main:576: bad speed value 0
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000013

Using device 0: ezcap USB 2.0 DVB-T/DAB/FM dongle
Found Rafael Micro R820T tuner
Oversampling input by: 21x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Tuned to 96552000 Hz.
Sampling at 1008000 Hz.
Output at 48000 Hz.
Exact sample rate is: 1008000.009613 Hz
Tuner gain set to automatic.
Signal caught, exiting!

User cancel, exiting...

I run Fedora 16 on a 64-bit AMD machine. aplay version is 1.0.26

If I break the command apart and generates a intermediate file it works but
using a pipe does not.

So is there some other shell that I where this might work or is there some
better why to do this?

Regards

Olof
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20121117/fa37fe50/attachment.html>


More information about the osmocom-sdr mailing list