GTP in previous kernels

fırat sönmez firatssonmez at gmail.com
Mon Jul 10 07:09:05 UTC 2017


Hi,

I am currently working on building a GTP tunnel between two hosts. I used
two virtual machines to implement GTP tunnel. The machines have the kernel
4.8 since GTP is in mainline. (I just did 'modprobe gtp') I setup the
tunnel with libgtpnl tools.

What I would like to do is that I want to have GTP module in a kernel 3.18.
I did some google search and then I added the headers, libraries and the
source code to the source code of 3.18 to compile all the kernel, but it
didnt work. I am not experienced in kernel module programming or about the
consequences compiling GTP in previous kernels which have different
structural mechanisms than the 4.* versions.

Is there any way to achieve this? If so, how could it be possible to get
help from this community?

Thanks all,
Fırat
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-net-gprs/attachments/20170710/9cd6bb7b/attachment-0001.html>


More information about the osmocom-net-gprs mailing list