I have a problem compiling osmocombb in Ubuntu 14.04

Andi Kita akita at qmail.qcc.edu
Mon Jan 21 03:47:26 UTC 2019


I had to commit my changes so that's why. After I committed my changes. It
worked. But now its lookig for talloc.h but after doing apt-get install
libtalloc-dev it has not found it yet. But I would give it a try tomorrow
when I manually compile talloc.

On Sun, Jan 20, 2019, 9:43 PM Andi Kita <akita at qmail.qcc.edu wrote:

> satel at satel-HP-Pavilion-Notebook:/home/imsicatcher/osmocom-bb/src/shared$
> sudo ./update-libosmocore.sh
> remote: Counting objects: 7821, done.
> remote: Compressing objects: 100% (4516/4516), done.
> remote: Total 7821 (delta 5871), reused 4635 (delta 3282)
> Receiving objects: 100% (7821/7821), 1.36 MiB | 1.01 MiB/s, done.
> Resolving deltas: 100% (5871/5871), completed with 271 local objects.
> From git://git.osmocom.org/libosmocore
>  * branch            master     -> FETCH_HEAD
> Auto-merging src/shared/libosmocore/src/vty/vty.c
> Auto-merging src/shared/libosmocore/src/vty/logging_vty.c
> CONFLICT (content): Merge conflict in
> src/shared/libosmocore/src/vty/logging_vty.c
> Removing src/shared/libosmocore/src/talloc.c
> Auto-merging src/shared/libosmocore/src/gb/gprs_ns_vty.c
> CONFLICT (content): Merge conflict in
> src/shared/libosmocore/src/gb/gprs_ns_vty.c
> Auto-merging src/shared/libosmocore/src/gb/gprs_bssgp_vty.c
> CONFLICT (content): Merge conflict in
> src/shared/libosmocore/src/gb/gprs_bssgp_vty.c
> Auto-merging src/shared/libosmocore/src/counter.c
> Auto-merging src/shared/libosmocore/include/osmocom/gsm/gsm48_ie.h
> Auto-merging src/shared/libosmocore/include/osmocom/core/linuxlist.h
> Removing src/shared/libosmocore/doc/vty/merge_doc.xsl
> Removing src/shared/libosmocore/debian/patches/debian-changes-0.1.17-1
> Removing src/shared/libosmocore/debian/libosmocore-dev.dirs
> Removing src/shared/libosmocore/debian/libosmocore-dbg.install
> Removing src/shared/libosmocore/debian/libosmocore-dbg.dirs
> Removing src/shared/libosmocore/debian/docs
> Automatic merge failed; fix conflicts and then commit the result.
>
>
> On Sun, Jan 20, 2019, 9:20 PM Vadim Yanitskiy <axilirator at gmail.com wrote:
>
>> > It is the same version of libosmocore that comes with osmocombb.
>>
>>
>> https://osmocom.org/projects/baseband/wiki/Software_Getting_Started#Dependencies-for-the-host
>>
>> > For osmocomBB, as for several other osmocom projects, you will also
>> need libosmocore.
>> > Note: Although libosmocore is included when getting osmocom-bb from the
>> git repository,
>> > you have to install it separately. The libosmocore subtree is only used
>> to compile the
>> > embedded ARM version of libosmocore.
>>
>> With best regards,
>> Vadim Yanitskiy.
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20190120/1ad31bca/attachment.html>


More information about the baseband-devel mailing list