Loading HelloWorld firmware in Motorolla C118

Mychaela Falconia mychaela.falconia at gmail.com
Wed Dec 26 16:16:44 UTC 2018


> I have also attached a cu terminal by using following command.
> $ sudo cu -l /dev/ttyUSB0 -s 115200
> The cu terminal displays this message on pressing power button.
> [garbage characters]ftmtoolerror

The series of non-printable-ASCII characters followed by "ftmtoolerror"
is exactly what Compal's bootloader emits on boot (the non-printable-
ASCII characters constitute PROMPT1 for a possible external code
download), so the fact that you are seeing these characters with your
cu terminal proves that your phone is good (has an unlocked bootloader)
and that your serial cable is good at least in the phone to PC
direction.  It is possible that your cable may be broken in the PC to
phone direction, or that the headset jack connection inside the phone
itself is broken in that direction - I have seen such broken headset
jack connections on some busted-up phones.  However, this other part
of your report raises other concerns:

> sudo ./osmocon -p /dev/ttyUSB0 -m c123xor ../../target/firmware/board/compal_e88/hello_world.compalram.bin
>
> But I am not getting any response on pressing power button briefly.
> The command keeps on executing without any message.

Are you saying that absolutely *no messages whatsoever* appear in the
console window where you run osmocon as you press thr power button on
the phone?  If so, then you must have some other problem, as osmocon
should at least report that it got PROMPT1 from the phone, even if it
is not successful in talking back to the phone.

M~


More information about the baseband-devel mailing list