Couldn't get connectivity to Motorolla c118 on writing osmocombb

Anton Gorbachev antgorka at gmail.com
Mon Jun 5 07:14:26 UTC 2017


Hi,

Which USB-TTL converter do you use?
What is the output of PuTTY and mincom? Post it here.
Try using -m c123 instead of -m c123xor

KR,
Anton

2017-06-05 8:30 GMT+03:00 baymax Robo <baymax254 at gmail.com>:

> HI again,
>
> I replaced my ttl converter, now my phone is able to communicate via
> serial port but osmocon is unable to write hello world binary. The output
> of following command is given
>
> $ ./osmocon -p /dev/ttyUSB0 -m c123xor ../../target/firmware/board/
> compal_e88/hello_world.compalram.bin
>
>
> output:
>
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: f7  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 3 bytes from modem, data looks like: 82 bf 7d  ..}
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: f7  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: fb  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: fb  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: f7  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: ff  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: f7  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: f7  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: fb  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 72  r
> got 1 bytes from modem, data looks like: 82  .
> got 1 bytes from modem, data looks like: bf  .
> got 1 bytes from modem, data looks like: 7d  }
> got 1 bytes from modem, data looks like: fd  .
> got 1 bytes from modem, data looks like: 7f  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: a6  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: d2  .
> got 1 bytes from modem, data looks like: 51  Q
> got 1 bytes from modem, data looks like: 0a  .
> got 1 bytes from modem, data looks like: 3a  :
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 4d  M
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: a3  .
> got 1 bytes from modem, data looks like: da  .
> got 1 bytes from modem, data looks like: 00  .
> got 1 bytes from modem, data looks like: 00  .
>
>
> and output on putty is unreadable. Kindly guide me what's wrong and how
> can it be fixed.
> Thanks
>
> On Thu, Jun 1, 2017 at 12:39 PM, Anton Gorbachev <antgorka at gmail.com>
> wrote:
>
>> If you cannot get @ftmtoolerror with minicom then your jack is NOT
>> working or your TTL converter is broken (was burnt during soldering?:)
>>
>> If you have another OS (e.g. Windows machine) you can put the device in
>> the PC, find out which serial line it is using,
>> run PuTTY, set Destination to Serial, COM9 (or what you find out),
>> speed 115200, connect.
>> Then push the power button on motorola, you must see @ftmtoolerror there.
>> If not, try another jack, another TTL converter, remove phone plastic case
>> as I told already..
>>
>> No more ideas :)
>>
>> KR,
>> Anton
>>
>>
>> 2017-06-01 10:27 GMT+03:00 baymax Robo <baymax254 at gmail.com>:
>>
>>> Oh okay. The headphone jack is working fine, i have tested it. And
>>> helloworld isn't working. Can you tell some other method to test phones
>>> connectivity with my system.
>>>
>>> On Thu, Jun 1, 2017 at 12:16 PM, Anton Gorbachev <antgorka at gmail.com>
>>> wrote:
>>>
>>>> Hi,
>>>>
>>>> Check the picture
>>>> https://osmocom.org/attachments/download/2091/motorola_c123_
>>>> hello_world.jpg
>>>>
>>>> I mean the outer plastic case of the phone may not allow your jack to
>>>> be inserted at the whole length to thoe whole even if it looks like OK.
>>>> It depends on your jack case shape.
>>>>
>>>> KR,
>>>> Anton
>>>>
>>>> 2017-06-01 9:57 GMT+03:00 baymax Robo <baymax254 at gmail.com>:
>>>>
>>>>> Hi,
>>>>>
>>>>> Thanks for replying back.
>>>>>
>>>>> I am not using virtualized environment. No success with minicom test.
>>>>> What exactly do you mean by jack is being plugged on the whole length, i
>>>>> didn't get it.
>>>>>
>>>>>
>>>>> On Thu, Jun 1, 2017 at 11:16 AM, Anton Gorbachev <antgorka at gmail.com>
>>>>> wrote:
>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Are you sure the jack is being plugged on the whole length?
>>>>>> Did you get success with minicom test?
>>>>>> I would recommend you to disassemble phone and check whether the jack
>>>>>> plugged an the whole length.
>>>>>> Do you use virtualized OS or normal? If virtualized, try to play with
>>>>>> the settings.
>>>>>>
>>>>>> KR,
>>>>>> Anton
>>>>>>
>>>>>> 2017-06-01 7:30 GMT+03:00 baymax Robo <baymax254 at gmail.com>:
>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> I am trying to write osmocombb to Motorolla c118 phone by following
>>>>>>> the given [1] guide.I have successfully compiled firmware binaries but
>>>>>>> having issues while writing them to phone.
>>>>>>>
>>>>>>> I connected motorolla c118 via USB Serial To RS232 TTL to 2.5mm
>>>>>>> audio jack, using the given guide [2]
>>>>>>>
>>>>>>> When I run this command
>>>>>>>
>>>>>>> $ dmesg | grep tty
>>>>>>>
>>>>>>> I get the following output
>>>>>>>
>>>>>>> [    0.000000] console [tty0] enabled
>>>>>>> [   14.946936] usb 3-6: pl2303 converter now attached to ttyUSB0
>>>>>>> [  973.747957] pl2303 ttyUSB0: pl2303 converter now disconnected
>>>>>>> from ttyUSB0
>>>>>>> [ 1484.595816] usb 3-6: pl2303 converter now attached to ttyUSB0
>>>>>>> [ 1845.344494] pl2303 ttyUSB0: pl2303 converter now disconnected
>>>>>>> from ttyUSB0
>>>>>>> [ 2643.566407] usb 3-6: pl2303 converter now attached to ttyUSB1
>>>>>>>
>>>>>>> And on running this
>>>>>>>
>>>>>>> $ sudo cu -l /dev/ttyUSB1 -s 115200
>>>>>>>
>>>>>>> I get a connected message but no further progress is done. When i
>>>>>>> press Power button briefly, no activity is shown. I have tried with two
>>>>>>> phones but no success on any. I have checked the connectivity between
>>>>>>> headphone jack and USB serial chip via voltmeter, it is fine as well. Also
>>>>>>> tried by doing Master reset on phone but no use. What can be issue and how
>>>>>>> can i fix it. ?
>>>>>>>
>>>>>>> Kindly ignore any mistakes, i am new to this domain, couldn't find
>>>>>>> much help on google as well :(
>>>>>>>
>>>>>>> [1]
>>>>>>> https://osmocom.org/projects/baseband/wiki/Software_Getting_Started
>>>>>>> https://osmocom.org/projects/baseband/wiki/Osmocon
>>>>>>>
>>>>>>> [2]
>>>>>>> http://www.linuxx.eu/2014/09/osmocombb-hardware-and-software
>>>>>>> -setup.html
>>>>>>>
>>>>>>> [2]
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20170605/9769f8c4/attachment-0001.html>


More information about the baseband-devel mailing list