Aw: Re: osmocombb and raspberry pi

Tim Ehlers osmocom at ehlers.info
Wed Feb 20 14:36:06 UTC 2013


On Wed, 20 Feb 2013, Richard Menedetter wrote:

Hi Richard,

> I have tried it on Raspberry Pi.
> First I thought both are ARM, so no crosscompile needed.
> I think the hello world example worked, but nothing else.
>
> So I searched for a crosscompile howto, and compiled another Toolchain on the Pi.
> That worked much better.
> I did not use the internal UART, but used an external USB dongle.
> I could use the RSSI monitor, and also the layer1 worked to some extent.
> I could see the phone making the channel measurements, but at the end it did not associate with any channel.
>
> Does somebody have a setup on RPi where he/she can make actual calls 
> (and hence associate with a cell)? If yes could you share how you did 
> it? (maybe I compiled to the wrong platform?)

mhh, I did it the same way. I use the raspbian image from the raspberry pi 
foundation. I compiled exactly this version:

http://bb.osmocom.org/trac/wiki/GnuArmToolchain

My raspberry is resetting when I pull the USB-UART Adapter. But if it is 
present while booting, I can use /dev/ttyUSB0 and the mobile-app is 
working like on x86-Architecture:

OsmocomBB# show ms
MS '1' is up, service is normal
   IMEI: 3532900XXXXXXXX
      IMEISV: 353290XXXXXXXXXX
      IMEI generation: fixed
   automatic network selection state: A2 on PLMN
                                      MCC=262 MNC=07 (Germany, O2)
   cell selection state: C3 camped normally
                         ARFCN=XXX(DCS) MCC=262 MNC=07 LAC=0xXXXX CELLID=0xXXXX
                         (Germany, O2)
   radio ressource layer state: idle
   mobility management layer state: MM idle, normal service


Even OpenBTS with sylvain-testing code is working.

Cheers

Tim




More information about the baseband-devel mailing list