Problem building OsmocomBB

Dennis Weider kandanalor at googlemail.com
Thu Mar 22 01:33:14 UTC 2012


Am 22. März 2012 01:56 schrieb Dennis Weider <kandanalor at googlemail.com>:
> Hi!
> I tried this tutorial to build my osmocomBB enviroment:
> http://bb.osmocom.org/trac/wiki/GettingStarted
> I downloaded the gnuarm toolchain from here:
> http://bb.osmocom.org/trac/wiki/toolchain
> I set the Path and i tried make, but it stops at
>
>> arm-elf-ld: ../../shared/libosmocore/build-target/src/.libs/libosmocore.a(msgb.o): Relocations in generic ELF (EM: 3)
>> ../../shared/libosmocore/build-target/src/.libs/libosmocore.a: could not read symbols: File in wrong format
>> make[1]: *** [board/compal_e88/hello_world.compalram.elf] Fehler 1
>
> I found a similar Thread on the mailing list here:
> http://baseband-devel.722152.n3.nabble.com/unknown-error-td2758006.html#a2763434
> But there is not a solution for the problem
>
> I would be happy if anybody would be able to giv a solution.
> MFG Kandanalor

With help of the mailing list I realized that first time i tried to
compile I hadn't my cross compiler in PATH.
A "git clean -dfx" and "make" fixed the problem

MFG Kandanalor




More information about the baseband-devel mailing list