nuxttx-bb issues

Denis 'GNUtoo' Carikli GNUtoo at no-log.org
Mon Feb 20 20:07:38 UTC 2012


hi,

Me and Alan Carvalho de Assis tried nuttx-bb on the calypso and we failed to 
get any serial or sercomm output.

The setup:
------------
1) clone the following repository(or add as remote  and checkout the correct 
branch):
git://git.osmocom.org/osmocom-bb
git://gitorious.org/gnutoo-s-for-upstream-osmocom-bb-and-nuttx-bb/nuttx-bb-
gta02.git
osmocom-bb and nuttx-bb-gta02 must be in the same directory.
nuttx-bb-gta02 has 2 small patches made by me.

One is for fixing compilation.
And the other one is the result of a diff between compal_e99's init.c and the 
gta02's init.c

2) setup the toolchain:
we didn't use gnuarm toolchain because it gave that when compiling nuttx-bb:
arm-elf-ld: ERROR: /home/gnutoo/temp/osmo/nuttx-bb-gta02/nuttx/../../osmocom-
bb/src/target/firmware/comm/libcomm.a(sercomm.o) uses hardware FP, whereas 
/home/gnutoo/temp/osmo/nuttx-bb-gta02/nuttx/nuttx uses software FP
So we tried the arm-2010.09 codesourcey
we put it in the path.

3) compile osmocom-bb:
cd osmocom-bb/src
make clean
make
cd ../../

3) compile nuttx-bb:
cd nuttx-bb-gta02/nuttx
cd tools
./configure.sh compal_e99/nsh
cd ../
make CROSSDEV="arm-none-eabi-" clean
make CROSSDEV="arm-none-eabi-"

that gives a file named nuttx.bin

Then I tried it to load on my om-gta02:
scp nuttx.bin root at 192.168.7.2:
ssh root at 192.168.7.2

root at om-gta02:~# /etc/init.d/dbus-1 stop
Stopping system message bus: root at om-gta02:~# /etc/init.d/xserver-nodm stop
Stopping XServer
root at om-gta02:~# osmocon -i 13 -m romload -p /dev/ttySAC0 nuttx.bin 
and on another console:
ssh root at 192.168.7.2
root at om-gta02:~# echo 1 > /sys/bus/platform/devices/gta02-pm-gsm.0/download
root at om-gta02:~# echo 0 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on
root at om-gta02:~# echo 1 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on
which results in the following on the first console:
[...]
Finished, sent 63 blocks in total
Received block ack from phone
Sending checksum: 0xf6 
Checksum on phone side matches, let's branch to your code
Branching to 0x00820000
Received branch ack, your code is running now!

but nothing on sercomm.
And nothing on IRDA serial port either....

and IRDA serial cable works too:
if I do that again:
root at om-gta02:~# echo 0 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on
root at om-gta02:~# echo 1 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on
I get the default modem software messages on the serial port...

Previously I tried to print on the IRDA serial port with:
cons_puts("HELLO WORLD\n\n");
in apps/examples/hello/main.c and of course enabling the hello world 
application in the apps config.
Nothing was printed either....

here's the app config:

CONFIGURED_APPS += examples/hello
in apps/.config

And here's the diff for the application:
diff --git a/apps/examples/hello/main.c b/apps/examples/hello/main.c
index 308603f..db55ac3 100644
--- a/apps/examples/hello/main.c
+++ b/apps/examples/hello/main.c
@@ -58,7 +58,10 @@
 
 int user_start(int argc, char *argv[])
 {
-  printf("Hello, World!!\n");
-  return 0;
+  while (1){
+    cons_puts("HELLO WORLD\n");
+    printf("Hello, World!!\n");
+ }
+ return 0;
 }

Alan Carvalho de Assis tried on features phones and not on the gta02 with the 
same result...

Denis.




More information about the baseband-devel mailing list