First OsmocomBB Connection Tests (Unsuccessful)

Drasko DRASKOVIC drasko.draskovic at gmail.com
Mon May 30 22:24:07 UTC 2011


On Tue, May 31, 2011 at 12:09 AM, Gianni Tedesco
<gianni at scaramanga.co.uk> wrote:
>> Synchronize_TDMA
>> LOST 3054!
>>
>> What would this LOST 3054! say ? It does not sound good anyway, but at
>> this point I am not skilled enough to read OsmocomBB logs.
>
> That's fine/normal.

OK, good. Sounds scary, though. I would prefer FIND message when
things go righth :).


>
> ...
>> PLMN selection in state 'A6 no SIM inserted'
>>
>>
>> Can somebody explain me what the hell is happening here ?
>
> No SIM inserted ;)
>
> You have 3 options:
> 1. Check out sylvain's testing branch for a working on-phone SIM driver
> 2. Use the SAP interface to a PC/SC smartcard reader with SIM inserted.
> 3. If you want to use GSM test set instead of real network, use test sim
>   functionality of mobile

Hmm.. I was convinced that there was some kind of SIM card simulation
implemented in the software and that for basic connection no physical
SIM card was needed...

So, as I understood, to have a cell attachment and to have some
packets exchange I will need to pull Sylvain's branch, as I have no
network nor PC/SC SIM card reader...

> Hope that helps.

Yes indeed. I had no idea what was happening, as I was expecting code
from the master branch to be operational. I saw NO SIM warning, but as
I told you, I thought that there was a SW SIM simulation
implementation somewhere inside protocol stack and that no real SIM
card was needed for the basic communication (I just want to see few
packets coming down the stack to get idea of data flow, so I can later
look at the source code and see how they are processed at each layer).

Thanks !

BR,
Drasko




More information about the baseband-devel mailing list