First OsmocomBB Connection Tests (Unsuccessful)

Gianni Tedesco gianni at scaramanga.co.uk
Mon May 30 22:09:23 UTC 2011


On Mon, 2011-05-30 at 23:41 +0200, Drasko DRASKOVIC wrote:
...
> OSMOCOM Layer 1 (revision osmocon_v0.0.0-884-gd76345a)
> ======================================================================
> Device ID code: 0xb4fb
> Device Version code: 0x0000
> ARM ID code: 0xfff3
> cDSP ID code: 0x0128
> Die ID code: 2c903414df039b3f
> ======================================================================
> REG_DPLL=0x2413
> CNTL_ARM_CLK=0xf0a1
> CNTL_CLK=0xff91
> CNTL_RST=0xfff3
> CNTL_ARM_DIV=0xfff9
> ======================================================================
> 
> 
> THIS FIRMWARE WAS COMPILED WITHOUT TX SUPPORT!!!

You might want to compile with transmit support if you expect to be able
to make calls and so forth, its explained on the wiki ;)

...
> L1CTL_RESET_REQ: FULL!L1CTL_FBSB_REQ (arfcn=121, flags=0x7)
> Starting FCCH RecognitionFB0 (1735:8): TOA= 9600, Power= -52dBm, Angle= 1218Hz
> FB1 (1745:8): TOA= 9563, Power= -52dBm, Angle=  174Hz
>   fn_offset=1744 (fn=1745 + attempt=8 + ntdma = 7)m  delay=9
> (fn_offset=1744 + 11 - fn=1745 - 1
>   scheduling next FB/SB detection task with delay 9
> =>FB @ FNR 1744 fn_offset=1744 qbits=3068
> Synchronize_TDMA
> LOST 3054!
> 
> What would this LOST 3054! say ? It does not sound good anyway, but at
> this point I am not skilled enough to read OsmocomBB logs.

That's fine/normal.

...
> PLMN selection in state 'A6 no SIM inserted'
> 
> 
> Can somebody explain me what the hell is happening here ?

No SIM inserted ;)

You have 3 options:
1. Check out sylvain's testing branch for a working on-phone SIM driver
2. Use the SAP interface to a PC/SC smartcard reader with SIM inserted.
3. If you want to use GSM test set instead of real network, use test sim
   functionality of mobile

See the 'sim' commands in mobile vty interface, and also try looking
around with enable; configure terminal; ms 1

> I am watching all these nice Harald's presentations, like one here :
> http://www.youtube.com/watch?v=H7rNKZdASBE, but I am not obtaining
> list of cells like presented to which I can synchronize to. Actually,
> show cell is giving me :
> 
> OsmocomBB> show cell 1
> arfcn  |MCC    |MNC    |LAC    |cell ID|forb.LA|prio   |min-db |max-pwr|rx-lev
> -------+-------+-------+-------+-------+-------+-------+-------+-------+-------

Should be fine after you solve the two above-mentioned problems. The
cell table can be a bit laggy anyway... Sometimes even when everything
works it takes a long time to register to the network and I don't get
cell info until after that succeeded.

> OsmocomBB>
> 
> As you can see, I am pretty much lost here and I would highly
> appreciate helping hand.

Hope that helps.

Gianni





More information about the baseband-devel mailing list