Sim on C115 & C118

Dobrica Pavlinusic dpavlin at rot13.org
Mon Jan 17 15:13:28 UTC 2011


On Mon, Jan 17, 2011 at 03:23:13PM +0100, Dario Lombardo wrote:
> Hello everybody
> I'm trying to run the "mobile" application on a C115 and a C118
> phone. I want to use the real sim, so I used "sim reader" in the
> config. Both phones have the same behaviour:
> 
> <000e> sim.c:1206 init SIM client
> <0005> gsm48_cc.c:61 init Call Control
> <0001> gsm48_rr.c:4944 init Radio Ressource process
> <0004> gsm48_mm.c:1220 init Mobility Management process
> <0004> gsm48_mm.c:971 Selecting PLMN SEARCH state, because no SIM.
> <0002> gsm322.c:3471 init PLMN process
> <0003> gsm322.c:3472 init Cell Selection process
> Mobile '1' initialized, please start phone now!
> VTY available on port 4247.
> <0004> subscriber.c:556 Requesting SIM file 0x2fe2
> <000e> sim.c:209 got new job: SIM_JOB_READ_BINARY (handle=00000004)
> <000e> sim.c:697 go MF
> <000e> sim.c:241 SELECT (file=0x3f00)
> <000e> sim.c:187 sending APDU (class 0xa0, ins 0xa4)
> 
> no more output beyond this point.
> Phones work correctly with other softwares, sim works correctly. I
> get no response from the sim. Is the card reader working on these
> phones? If yes, does anyone have suggestions to solve this issue?

Are you using sylvain/testing branch from git?

I did test (with success) sim with same two phones, and collected some
useful hints about configuration at:

http://blog.rot13.org/2011/01/osmocom-bb_-_free_software_finally_comes_to_gsm.html

(please note recommendation to use gnu-arm cross compiler!)

-- 
Dobrica Pavlinusic               2share!2flame            dpavlin at rot13.org
Unix addict. Internet consultant.             http://www.rot13.org/~dpavlin




More information about the baseband-devel mailing list