R: Re: GPRS Vs EDGE - Trying to decode my own sessions

Luca Bongiorni luca.bongiorni1 at studenti.unimi.it
Mon Aug 29 21:00:23 UTC 2011


Hi all,

just to explain what i mean, i've attached a sample and the log from layer23.

http://pastebin.com/pepx0tdv

As you can see from the log i got the immediate-assign. and the i can see the slots.

The only thing that i could be strange is the signal strength that sometimes is good and sometimes reaches -100 dBm.

Here is the gprsdecode's output: http://pastebin.com/p7XrtKAt

Obviously i tried other ARFCNs of all operators (with different c118/c123, FTDI cable) and i got always the same behaviour.

Have you some hints to suggest?


Tomorrow i will try with some DP-L10 and pubblish the relative results.


P.S: As i already stated, Nohl's samples are well decoded and showed into wireshark.


Regards,
Luca


> Hi Harald,
> 
> Actually i could use some old phones that supports only GPRS (e.g. t68i, t39m, etc..), but these phones are not enough useful and i will explain why:
> 
> - i would like to use a phone that has field-test engineering;
> - i would like to set the phone to camp only in a fixed ARFCN.
> 
> I was also trying a Pirelli DP-L10, but unfortunately i can only fix the band and not the arfcn. 
> 
> 
> Btw... after a while i finally found how to force my Blackberry to work on GPRS on a fixed arfcn:
> 
> - Select an arfcn;
> - Lock to this cell;  [ http://tinyurl.com/3dcc6vm ]
> - Disable Uplink 8-PSK; [ http://tinyurl.com/3dxp85d ]
> 
>  Finally the phone is ready to start the tests. [ http://tinyurl.com/3rhldrn ]
> 
> 
> As you can see, that engineering field-test is very useful because is showing which Coding Scheme and TS are used.
> 
> 
> Unfortunately at this point... even if i tried a lot of times, i could see imm-ass, the TS, but when i'm trying to decode the dumps... nothing is decoded and i cannot even decode third-party sessions that obviously i could find on the same arfcn that i'm using.
> 
> So, at this state of art, I could decode only samples released from Nohl.
> Someone else is having same problems?
> 
> 
> Regards,
> 
> Luca
> 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bursts_20110729_2215_112_1463626_0e.dat
Type: application/x-ns-proxy-autoconfig
Size: 49100 bytes
Desc: not available
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110829/21a6333c/attachment.bin>


More information about the baseband-devel mailing list