libosmocore/osmocombb build error

Harald Welte laforge at gnumonks.org
Sun Aug 21 08:09:19 UTC 2011


On Sat, Aug 20, 2011 at 10:10:44PM +0200, Job wrote:
> Hi,
> 
> When building osmocombb with an updated src/shared/libosmocore (0.3.6)
> the build fails due to make attempting to build utils/osmo-arfcn.c for
> build-target which does not have stdio.
> 
> I have no patch as I was not sure what the preferred way to solve it is.
> Maybe a --disable-utils like for tests?

I think we should introduce something like "--enable-embedded" as one
global setting that would unify the following parts:
	* disable tests (so far: --disable-tests)
	* disable msgfile (so far: --disable-msgfile)
	* disable plugins (so far: --disable-plugin)
	* disable utilities (no way to disable so far)

so you can remove the --disable-{tests,msgfile,plugin} and simply
replace it with the new --enable-embedded.

I'd be happy to merge a patch that takes care of this (as well as the
osmocom-bb/src/Makefile changes related to it)

Regards,
	Harald
-- 
- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)




More information about the baseband-devel mailing list