build issues on OSX

Nathan Fain nat at fains.com
Sun Mar 14 10:10:41 UTC 2010


Thanks for the nudge.  I had this setup already but first make run i did
was with a PATH set to a osx installed aclocal and for some reason my make
clean was also dieing. Anyway, rebased the repo and ran make with proper
PATH.  Now I'm only getting Error 3 mentioned before:

arm-elf-ld -nostartfiles -nostdlib -nodefaultlibs --gc-sections  -T
board/common/compal_ramload.lds -Bstatic -Map
board/compal_e88/hello_world.map  -o board/compal_e88/hello_world.elf
--start-group apps/hello_world/main.o board/common/compal_ramload_start.o
abb/twl3025.o rf/trf6151.o display/font_r8x8.o display/font_r8x8_horiz.o
display/st7558.o display/ssd1783.o display/display.o flash/cfi_flash.o
calypso/libcalypso.a layer1/liblayer1.a lib/libmini.a comm/libcomm.a
../../shared/libosmocore/build-target/src/.libs/libosmocore.a
board/common/rffe_compal_dualband.o board/compal_e88/init.o
board/compal_e88/board.o --end-group
calypso/libcalypso.a: could not read symbols: Archive has no index; run
ranlib to add one
make[1]: *** [board/compal_e88/hello_world.elf] Error 1
make: *** [firmware] Error 2


I have this setup:

$ /opt/local/bin/aclocal --version
aclocal (GNU automake) 1.11
$ pkg-config --version
0.23
$ /opt/local/bin/aclocal --print-ac-dir
/opt/local/share/aclocal
$ ls  /opt/local/share/aclocal/pkg.m4 
/opt/local/share/aclocal/pkg.m4

Concerning the recommendation to use ranlib... the macport install of
liblocal doesnt include ranlib support.  liblocal docs say ranlib has been
deprecated with 'liblocal --static'.  I suppose I could find or compile a
version that supports ranlib.  Do we require this?

-- 
cyphunk://cypherpoet.com
nathan://squimp.com
fain://deadhacker.com




More information about the baseband-devel mailing list