problem starting out...please help

Peter Stuge peter at stuge.se
Tue Aug 31 14:04:57 UTC 2010


Scott Weisman wrote:
> /usr/bin/arm-elf-ld: this linker was not configured to use sysroots
> collect2: ld returned 1 exit status

As always, it would be helpful to also see the last few commands that
were executed, to get more context.


> I am running Arch Linux and have the packages cross-arm-elf-binutils
> and cross-arm-elf-gcc-base installed. Does anyone have any
> suggestions to fix this?

Mh. My guess is that toolchain is intended for building Linux
systems, or in any case building "systems" with some packaging
support, and intent to install into a root filesystem - as opposed
to just cross-compiling bare metal sources with no filesystem ever
involved..

I assume you've googled for arch and this error and have found
https://bbs.archlinux.org/viewtopic.php?id=62644 - and since you're
an Arch user maybe you already know what PKGBUILD and ABS are and how
they are intended to operate. (I've never used Arch, but I guess ABS
is Arch Build System, which might support my other guess that your
toolchain is just not suitable for building osmocom-bb.)


//Peter




More information about the baseband-devel mailing list