problem starting out...please help

Scott Weisman sweisman at pobox.com
Tue Aug 31 13:41:48 UTC 2010


Hi All,

I now have a V171 phone and cable so I thought I might get started with
this.

I checked out the code and started make. Osmocon built with no problem, but
I got this error next:

cd shared/libosmocore/build-target && ../configure \
                        --host=arm-elf-linux --disable-vty
--enable-panic-infloop \
                        --disable-shared --disable-talloc --disable-tests \
                CC="arm-elf-gcc" CFLAGS="-Os -ffunction-sections
-I../../../../target/firmware/include"
configure: WARNING: if you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for arm-elf-linux-strip... no
checking for strip... strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make sets $(MAKE)... (cached) yes
checking for arm-elf-linux-gcc... arm-elf-gcc
checking whether the C compiler works... no
configure: error: in
`/mnt/site/osmocom-bb/src/shared/libosmocore/build-target':
configure: error: C compiler cannot create executables
See `config.log' for more details
make: *** [shared/libosmocore/build-target/Makefile] Error 77

Checking config.log I can see it chokes here:

/usr/bin/arm-elf-ld: this linker was not configured to use sysroots
collect2: ld returned 1 exit status

I am running Arch Linux and have the packages cross-arm-elf-binutils
and cross-arm-elf-gcc-base installed. Does anyone have any suggestions to
fix this?

Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20100831/a498c168/attachment.html>


More information about the baseband-devel mailing list