Problem with firmware flashing

Alexander Unger alexander.u at keepgo.com
Wed Feb 8 09:25:26 UTC 2017


Hi, our company bought two SIMtrace Hardware Kits. We want to use SIM
forwarder
<https://github.com/kamwar/simlabTrace/wiki/res/bin/sim_forwarder-simtrace-at91sam7s128-flash_dfu.bin>
 firmware
in our project. but have problem with flashing it to the board.

in one way I installed toolchain as described at
http://osmocom.org/projects/baseband/wiki/GnuArmToolchain

and made forwarder firmware - success1.

but any tries to flash it using dfu-util failed.
tries was next:
--------------------------
- from windows10 host using steps from
https://github.com/kiibohd/controller/wiki/Loading-DFU-Firmware#windows -
kii-dfu can`t flash it due to three dfu devices with NO serial numbers.
Try using dfu-util with -a0 flag gives same result as later cases - DFU
found, state idle, activate alternative=0 ... and nothing more. reruns not
helps. reconnects with or w/o BOOTLOADER button gives same result - nothing.
---------------------
- same win10 host with vmWare Ubuntu16.04 VM. tries to install using
ubuntu. device shown on lsusb - dfu mode on. dfu-utils installed, toolchain
too, firmware made OK. simtrace made too.

BUG1
experiment with simtrace gives output with wrong parsing of commands - may
be you have to open bug case to resolve it. same results with usb2 on vm
and usb3.

all tries to flash forwarder or reader to board failed on same place as
before.
tried with button at connect and using -ao and w/o button and using -i
param (forgot number of interface for apps partition mb was -i1 ) - failed

- pure ubuntu 16.04 host. all above with same results. using usb3 port and
usb2 extender.
--------------------------------

Now the time to tell about second way - SAM-BA . here is another problem:

used http://osmocom.org/projects/simtrace/wiki/SIMtrace_Firmware

installed GnuArmToolchain
<http://osmocom.org/projects/baseband/wiki/GnuArmToolchain>. as described
on  toolchain <http://osmocom.org/projects/baseband/wiki/Toolchain> link,
included to PATH.

Trying to do:

git clone git://git.osmocom.org/openpcd.git
cd openpcd/firmware
make -f Makefile.dfu BOARD=SIMTRACE
make BOARD=SIMTRACE DEBUG=1 TARGET=main_simtrace
cat dfu.bin main_simtrace.bin > main_simtrace.samba
cd ../..

failed on 3rd string: make -f Makefile.dfu BOARD=SIMTRACE - arm-elf-gcc not
found!
tries to rename arm-none-eabi gcc to arm-elf-gcc was not successful. so I
cant produce
your dfu.bin to use samba (I made it with success) with

cat dfu.bin my_forwarder.bin > my_forwarder.samba


Also, at the string cat dfu.bin main_simtrace.bin > main_simtrace.samba we
see dfu.bin which is possibly dfu-boot-loader with wrong name which crashes
brain of google
so we have a BUG2:
- to rename produced dfu.bin filename to something relative i.e.
dfu-boot-loader-arm-SAM7.bin
- to place link to binary of loader(s) at your instructions.

installed also crosstool-ng - but arm-elf-gcc not found too

So, we have fails using dfu-util and unmaking state of firmware which gives
use of SAM-BA impossible due to insufficient dfu-boot-loader-arm-SAM7.bin
aka dfu-bin.

This situation looks like failed "smoke test"...

Please help me to solve these issues.

Regards,

Alexandr

-- 
https://L-in-K.com/147a258u369
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/simtrace/attachments/20170208/457e4170/attachment.html>


More information about the simtrace mailing list