Problems on CentOS 6.4 (64 bit)

Dan yo3ggx at gmail.com
Sat Oct 12 07:50:29 UTC 2013


Hi Pete,

On 10/12/2013 12:52 AM, Pete Zaitcev wrote:
> On Fri, 11 Oct 2013 20:27:57 +0300
> Dan <yo3ggx at gmail.com> wrote:
>
>> LIBUSB_LIBS and LIBUSB_CFLAGS
>> before running ./configure for rtl-sdr
> That's a bit indirect. The best way is to run ldd ./myapp
>
> I continue to maintain that all this advice about installing "latest"
> without knowing what's up is not likely to work. The stock libusb1 rpm
> from Koji works just fine, I would not even bother rebuilding it,
> just pull off an F14 repo.
The version of libusb1 in F14 is 1.0.8-1, but in CentOS 6.2 is newer 
(1.0.9-0.6.rc1).
I think now that I have another issue as I have tested with several 
libusb1-devel libraries, but without uninstalling original libusb1 from 
CentOS because of multiple dependencies.


> Find what the problem is by running strace ./rtl-sdr and matching ioctls
> to the code.
I need to read as I'm not familiar with this...
> -- Pete

Thank you,
Dan




More information about the osmocom-sdr mailing list