osmo-pcu.git branch master updated. a9e6dc5084627e7c279ba08de7a7809e97ebc539

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/osmocom-net-gprs@lists.osmocom.org/.

Alexander Chemeris alexander.chemeris at gmail.com
Sun Jun 17 09:51:54 UTC 2012


Ivan,

This is a dab approach to naming constants - prone to collisions with
some other names in future. Generic names like "RELEASE" are
particularly bad. You have to add some prefix to those names. This
should make reading the code easier as well.

 enum gprs_rlcmac_tbf_state {
-	GPRS_RLCMAC_WAIT_DATA_SEQ_START,
-	GPRS_RLCMAC_WAIT_NEXT_DATA_BLOCK,
-	GPRS_RLCMAC_WAIT_NEXT_DATA_SEQ
+	WAIT_ESTABLISH,
+	CCCH_ESTABLISH,
+	PACCH_ESTABLISH,
+	FINISH_ESTABLISH,
+	WAIT_DATA_TRANSFER,
+	DATA_TRANSFER,
+	FINISH_DATA_TRANSFER,
+	RELEASE
 };

On Sun, Jun 17, 2012 at 8:31 AM, git repository hosting
<gitosis at osmocom.org> wrote:
> This is an automated email from the git hooks/post-receive script. It was
> generated because a ref change was pushed to the repository containing
> the project "UNNAMED PROJECT".
>
> The branch, master has been updated
>       via  a9e6dc5084627e7c279ba08de7a7809e97ebc539 (commit)
>      from  9b06ff0c4c49f1927b9029d38e16670a7b7301fb (commit)
>
> Those revisions listed above that are new to this repository have
> not appeared on any other notification email; so we list those
> revisions in full, below.
>
> - Log -----------------------------------------------------------------
> http://cgit.osmocom.org/cgit/osmo-pcu/commit/?id=a9e6dc5084627e7c279ba08de7a7809e97ebc539
>
> commit a9e6dc5084627e7c279ba08de7a7809e97ebc539
> Author: Ivan Kluchnikov <kluchnikovi at gmail.com>
> Date:   Sun Jun 17 08:30:06 2012 +0400
>
>    Improvement of TBF management.
>    Added functions for TBF allocation, establishment, data transfer and release management.
>    Modified TBF structure, added list for several LLC PDUs in one TBF.
>    Added function gprs_rlcmac_tx_llc_pdus() providing transmission of several LLC PDUs in one TBF to MS.
>
> -----------------------------------------------------------------------
>
> Summary of changes:
>  src/gprs_bssgp_pcu.cpp |   41 ++--
>  src/gprs_rlcmac.cpp    |  674 ++++++++++++++++++++++++++++++++++--------------
>  src/gprs_rlcmac.h      |   79 +++++--
>  3 files changed, 561 insertions(+), 233 deletions(-)
>
>
> hooks/post-receive
> --
> UNNAMED PROJECT
>



-- 
Regards,
Alexander Chemeris.
CEO, Fairwaves LLC / ООО УмРадио
http://fairwaves.ru




More information about the osmocom-net-gprs mailing list