pySim ModuleNotFoundError: No module named 'construct'

Niels ten Oever lists at digitaldissidents.org
Fri Apr 30 13:57:21 UTC 2021


Thanks Neels,

I got one step further by running:

$ sudo apt install python3-construct

and felt kinda stupid when that worked. 

Unfortunately that did not solve all my issues, because then I got:

./pySim-read.py -p0         1 ↵  ⚙  1061  15:38:08
Traceback (most recent call last):
  File "/home/gagarin/.local/lib/python3.8/site-packages/qtpy/__init__.py", line 204, in <module>
    from PySide import __version__ as PYSIDE_VERSION  # analysis:ignore
ModuleNotFoundError: No module named 'PySide'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "./pySim-read.py", line 31, in <module>
    from pySim.ts_51_011 import EF, DF, EF_SST_map, EF_AD
  File "/home/gagarin/Data/pysim/pySim/ts_51_011.py", line 329, in <module>
    from pySim.filesystem import *
  File "/home/gagarin/Data/pysim/pySim/filesystem.py", line 31, in <module>
    import cmd2
  File "/home/gagarin/.local/lib/python3.8/site-packages/cmd2/__init__.py", line 30, in <module>
    from .cmd2 import Cmd
  File "/home/gagarin/.local/lib/python3.8/site-packages/cmd2/cmd2.py", line 73, in <module>
    from .clipboard import (
  File "/home/gagarin/.local/lib/python3.8/site-packages/cmd2/clipboard.py", line 14, in <module>
    _ = pyperclip.paste()
  File "/home/gagarin/.local/lib/python3.8/site-packages/pyperclip/__init__.py", line 680, in lazy_load_stub_paste
    copy, paste = determine_clipboard()
  File "/home/gagarin/.local/lib/python3.8/site-packages/pyperclip/__init__.py", line 582, in determine_clipboard
    import qtpy  # check if qtpy is installed
  File "/home/gagarin/.local/lib/python3.8/site-packages/qtpy/__init__.py", line 210, in <module>
    raise PythonQtError('No Qt bindings could be found')
qtpy.PythonQtError: No Qt bindings could be found

So I sought to install PySide:

sudo pip3 install -U PySide --no-cache-dir
Collecting PySide
  Downloading PySide-1.2.4.tar.gz (9.3 MB)
     |████████████████████████████████| 9.3 MB 5.1 MB/s 
    ERROR: Command errored out with exit status 1:
     command: /usr/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-eea4ncap/PySide/setup.py'"'"'; __file__='"'"'/tmp/pip-install-eea4ncap/PySide/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-lu1h2k1z
         cwd: /tmp/pip-install-eea4ncap/PySide/
    Complete output (1 lines):
    only these python versions are supported: [(2, 6), (2, 7), (3, 2), (3, 3), (3, 4)]
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

and it then turned out PySide only support Python up to 3.4. - which was quite surprising to me.

So I thought to set up an anaconda envuronmentwith Python 3.4, but the oldest Python3 version that is support by anaonconda is Python 3.5.4 argh.

My intermediate hypothesis is that things broke with recent Ubuntu update to a more recent Python version?

Thanks for the help and comments that might help me get on my way. 

Best,

Niels





On 30-04-2021 13:54, Neels Hofmeyr wrote:
> Your report seems really odd and not related to pysim but rather some
> unfortunate mixup of python library installation. Hard to tell from the
> distance.
> 
> Have you tried maybe running 'python3' (or 'ipython3') and entering
>   import construct
> on the prompt?
> 
> Is there maybe some discrepancy between /usr/local/lib, /usr/lib and your
> ~/.local/lib python library locations?
> 
> Maybe try running from a different user account, just in case your user's
> python config is somehow confused?
> 
> ~N
> 

-- 
Niels ten Oever, PhD
Postdoctoral Researcher - Media Studies Department - University of Amsterdam
Research Fellow - Centre for Internet and Human Rights - European University Viadrina
Associated Scholar - Centro de Tecnologia e Sociedade - Fundação Getúlio Vargas
Affiliated Factulty - Digital Democracy Insitute - Simon Fraser University

https://nielstenoever.net - mail at nielstenoever.net - @nielstenoever - +31629051853
PGP: 2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A C8B3

Read my latest article on Internet infrastructure governance in New Media & Society here: https://journals.sagepub.com/doi/full/10.1177/1461444820929320


More information about the OpenBSC mailing list