pySim ModuleNotFoundError: No module named 'construct'

Harald Welte laforge at gnumonks.org
Fri Apr 30 12:57:45 UTC 2021


Hi Niels,

On Fri, Apr 30, 2021 at 11:56:01AM +0200, Niels ten Oever wrote:
> $ /usr/bin/env python3 --version 
> Python 3.8.5
> 
> > which python version are you using to execute pySim?

strange.  Unfortuantely I'm not a python expert, and I'm not sure why the 'construct' you installed
using pip3 is not import-able by python.

All I can say is that I tested the new imports on Debian 9, 10 and unstable, and it
worked on those platforms.

There certainly are other people on this list who have a much deeper python
knowledge than I do.

-- 
- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)


More information about the OpenBSC mailing list