[PATCH 1/6] Use enum for subscriber creation policy

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/OpenBSC@lists.osmocom.org/.

Holger Freyther holger at freyther.de
Mon May 9 14:53:47 UTC 2016


> On 04 May 2016, at 13:02, msuraev at sysmocom.de wrote:
> 
> 


> +enum gsm_subscr_ext_alloc_policy {
> +	GSM_SUBSCR_DONT_CREATE = 0,
> +	GSM_SUBSCR_RANDOM_EXT = 1,
> +};


Neels reminded us to name things well. "extension alloc policy" is not the right word. The first item doesn't control the creation of the extension but the creation of the subscriber.

enum gsm_subscr_creation_mode {
	GSM_SUBSCR_DONT_CREATE
	GSM_SUBSCR_CREAT_W_RAND_EXT,
	GSM_SUBSCR_CREAT_W_NO_EXT
}>

> +
> enum gsm_security_event {
> 	GSM_SECURITY_NOAVAIL,
> 	GSM_SECURITY_AUTH_FAILED,
> diff --git a/openbsc/src/libbsc/net_init.c b/openbsc/src/libbsc/net_init.c
> index 568a0b8..00a8a9b 100644
> --- a/openbsc/src/libbsc/net_init.c
> +++ b/openbsc/src/libbsc/net_init.c
> @@ -48,7 +48,7 @@ struct gsm_network *gsm_network_init(uint16_t country_code, uint16_t network_cod
> 	INIT_LLIST_HEAD(&net->bsc_data->mscs);
> 
> 	net->subscr_group->net = net;
> -	net->create_subscriber = 1;
> +	net->create_subscriber = GSM_SUBSCR_RANDOM_EXT;

rename variable to creation_mode? or better name?





More information about the OpenBSC mailing list