Error - Installating libosmo-abis

Alexander Chemeris alexander.chemeris at
Sun Mar 22 19:29:26 UTC 2015


For OsmoTRX support in OpenBSC I recommend you to use
'fairwaves/master' branches where they exist - they are synchronized
to each other, as we're using them here.

On Fri, Mar 20, 2015 at 9:53 AM, Amber and Sarosh
<amber_sarosh at> wrote:
> Hi, I am trying to  configure and run OsmoTRX,OsmoBTS, OsmoNITB and LCR as
> per instructions at ;
> After installation of libosmocore when i run ./configure in
> libosmo-abis-master , I get the error below every time. Please note that I
> have installed libosmocore-0.6.0 but some how even while running pkg-config
> --modversion libosmocore command the version is reported as having value of
> UNKNOWN. I have also set the path of PKG_CONFIG_PATH correctly where the
> file libosmocore.pc is actually located but still this error is seen.
> checking if gcc supports -fvisibility=hidden... yes
> checking for pkg-config... /usr/bin/pkg-config
> checking pkg-config is at least version 0.9.0... yes
> checking for LIBOSMOCORE... no
> configure: error: Package requirements (libosmocore >= 0.3.0) were not met:
> Requested 'libosmocore >= 0.3.0' but version of Osmocom Core Library is
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> Alternatively, you may set the environment variables LIBOSMOCORE_CFLAGS
> and LIBOSMOCORE_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> Please help me in this regard.
> Regards,
> Sarosh

Alexander Chemeris.
CEO, Fairwaves, Inc.

More information about the OpenBSC mailing list