Error - Installating libosmo-abis

Amber and Sarosh amber_sarosh at hotmail.com
Fri Mar 20 06:53:40 UTC 2015




Hi, I am trying to  configure and run OsmoTRX,OsmoBTS, OsmoNITB and LCR as per instructions at ; 
http://openbsc.osmocom.org/trac/wiki/network_from_scratch
After installation of libosmocore when i run ./configure in libosmo-abis-master , I get the error below every time. Please note that I have installed libosmocore-0.6.0 but some how even while running pkg-config --modversion libosmocore command the version is reported as having value of UNKNOWN. I have also set the path of PKG_CONFIG_PATH correctly where the file libosmocore.pc is actually located but still this error is seen.

checking if gcc supports -fvisibility=hidden... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LIBOSMOCORE... no
configure: error: Package requirements (libosmocore >= 0.3.0) were not met:

Requested 'libosmocore >= 0.3.0' but version of Osmocom Core Library is UNKNOWN

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBOSMOCORE_CFLAGS
and LIBOSMOCORE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Please help me in this regard.

Regards,
Sarosh

 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/openbsc/attachments/20150320/4e9ef458/attachment.html>


More information about the OpenBSC mailing list