[op25-dev] SOLVED Audio to Darkce/IceCast Server - No audio???? No tags, Local audio good.

op25 at zellners.com op25 at zellners.com
Sat Jan 5 13:47:09 UTC 2019

Quoting op25 at zellners.com:

> Quoting op25 at zellners.com:
>> NO AUDIO still.  Tags... no audio on feed.

I found the issue...

rx.py options.

I read that you use -O loop0 so put that in the CLI for rx.py.

The PROBLEM IS that you REQUIRE -U as well....  Maybe thats clear to  
everyone else, but to me it reads OR not BOTH REQUIRED.. maybe   
documented the -U produces audio, *** to route that audio to a  
specific sound card or an ALSA plugin like snd-aloop you use the -O  
option AS WELL to specify where to send audio, other wise the DEFAULT  
audio device is used....ie: ALSA output etc..

Like :

Audio output:  -U [-O (device/plugin)]

Audio is produced on the local device with the -U option, OPTIONALLY  
you can route this to specific devices ie: non default sound card or  
ALSA plugins like snd-aloop to send to other programs like Darkice,  
etc. for streaming


-U will produce local audio

-U -O hw:1,0 would route that audio to a SECOND sound device, say a  
better unit than the standard built in DAC on most systems

-U -O loop0 would route it to the ALSA Loopback driver to send to  
other programs like Darkice for streaming or others.

I read that them as exclusive like using the nc | play wireshark  
output option is -U or -W NOT BOTH...

SO adding -U -O loop0 TOGETHER and MAGICALLY NOW AUDIO is present...

So SOLVED - OPERATOR ERROR...  Just didn't doesn't read that need -U  
AND then routing it via -O to me....

Any way THANKS for the input...


Now on to fine tunning and prepping the other Pi's to be ready for a  
PII cut over thats coming....

More information about the op25-dev mailing list