Change in pysim[master]: pySim-prog: rename card_handler option to card_handler_config

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

dexter gerrit-no-reply at lists.osmocom.org
Mon Sep 20 08:29:20 UTC 2021


dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/pysim/+/25508 )


Change subject: pySim-prog: rename card_handler option to card_handler_config
......................................................................

pySim-prog: rename card_handler option to card_handler_config

The option and also the dest variable in the code are currently named
card_handler. This might be confusing since the variable actually refers
to a config file and therefore should be called "card_handler_config"

Change-Id: If93751e815cb46f9ff3f56b54e612d77fe1a6dfd
---
M pySim-prog.py
1 file changed, 3 insertions(+), 3 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/08/25508/1

diff --git a/pySim-prog.py b/pySim-prog.py
index 3b69bb3..a8be2fb 100755
--- a/pySim-prog.py
+++ b/pySim-prog.py
@@ -200,7 +200,7 @@
 	parser.add_option("--dry-run", dest="dry_run",
 			help="Perform a 'dry run', don't actually program the card",
 			default=False, action="store_true")
-	parser.add_option("--card_handler", dest="card_handler", metavar="FILE",
+	parser.add_option("--card_handler_config", dest="card_handler_config", metavar="FILE",
 			help="Use automatic card handling machine")
 
 	(options, args) = parser.parse_args()
@@ -740,8 +740,8 @@
 	# Batch mode init
 	init_batch(opts)
 
-	if opts.card_handler:
-		ch = CardHandlerAuto(sl, opts.card_handler)
+	if opts.card_handler_config:
+		ch = CardHandlerAuto(sl, opts.card_handler_config)
 	else:
 		ch = CardHandler(sl)
 

-- 
To view, visit https://gerrit.osmocom.org/c/pysim/+/25508
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: If93751e815cb46f9ff3f56b54e612d77fe1a6dfd
Gerrit-Change-Number: 25508
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-MessageType: newchange
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210920/7cc80f1a/attachment.htm>


More information about the gerrit-log mailing list