Change in osmo-pcu[master]: Add stats: pcu.bts.N.pdch.occupied.gprs/egprs

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

osmith gerrit-no-reply at lists.osmocom.org
Fri Sep 17 08:47:44 UTC 2021


osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/25400 )

Change subject: Add stats: pcu.bts.N.pdch.occupied.gprs/egprs
......................................................................


Patch Set 3:

(5 comments)

https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/pdch.h 
File src/pdch.h:

https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/pdch.h@81 
PS2, Line 81: 	void num_tbfs_update(gprs_rlcmac_tbf *tbf, enum tbf_type type, bool is_attach);
> type should be known from tbf, no need to pass it?
Done


https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/pdch.cpp 
File src/pdch.cpp:

https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/pdch.cpp@1065 
PS2, Line 1065: 	enum tbf_type type = tbf->is_egprs_enabled() ? TBF_TYPE_EGPRS : TBF_TYPE_GPRS;
> why aren't you calling tbf->is_egprs_enabled() inside num_tbfs_update()!?
Done


https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/tbf.h 
File src/tbf.h:

https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/tbf.h@90 
PS2, Line 90: 	TBF_TYPE_GPRS,
> No need for this!
Are you sure? just using 0 and 1 there makes the code harder to read IMHO, e.g.

 return (m_num_tbfs[GPRS_RLCMAC_UL_TBF][TBF_TYPE_GPRS] + m_num_tbfs[GPRS_RLCMAC_DL_TBF][TBF_TYPE_GPRS]) > 0;

vs

 return (m_num_tbfs[GPRS_RLCMAC_UL_TBF][0] + m_num_tbfs[GPRS_RLCMAC_DL_TBF][0]) > 0;

and

 return m_num_tbfs[dir][TBF_TYPE_GPRS] + m_num_tbfs[dir][TBF_TYPE_EGPRS];

vs

 return m_num_tbfs[dir][0] + m_num_tbfs[dir][1];


https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/tbf.cpp 
File src/tbf.cpp:

https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/tbf.cpp@773 
PS2, Line 773: 	for (int ts = 0; ts < 8; ts++) {
> what about using ARRAY_SIZE(pdch) here instead of 8?
Done


https://gerrit.osmocom.org/c/osmo-pcu/+/25400/2/src/tbf.cpp@779 
PS2, Line 779: 		if (direction == GPRS_RLCMAC_DL_TBF && pdch[ts]->dl_tbf_by_tfi(m_tfi) != this)
> why are the last 2 if conditions needed? if pdch[ts] it means it's attached right? no need to do thi […]
If I remove the checks, it will run num_tbfs_update on PDCHs where _any_ TBF is attached, instead of only the PDCH where the relevant TBF ("this") is attached.



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/25400
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Change-Id: I0c0a1121b4ae5f031782e7e63a0c28eb0b6c8b42
Gerrit-Change-Number: 25400
Gerrit-PatchSet: 3
Gerrit-Owner: osmith <osmith at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Fri, 17 Sep 2021 08:47:44 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210917/80c8e9b3/attachment.htm>


More information about the gerrit-log mailing list