Change in osmo-bsc[master]: cosmetic: rename lchan_activate_mode to lchan_activate_for

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

neels gerrit-no-reply at lists.osmocom.org
Wed May 19 17:11:32 UTC 2021


neels has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-bsc/+/24301 )


Change subject: cosmetic: rename lchan_activate_mode to lchan_activate_for
......................................................................

cosmetic: rename lchan_activate_mode to lchan_activate_for

In subsequent patches, I will add enum lchan_modify_for and enum
assignment_for, I prefer to have similar lchan_activate_for naming.

Change-Id: Ia4420fcd1234dbee92e768e5a32eab13fba29ea9
---
M include/osmocom/bsc/gsm_data.h
M src/osmo-bsc/lchan_fsm.c
2 files changed, 4 insertions(+), 4 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/01/24301/1

diff --git a/include/osmocom/bsc/gsm_data.h b/include/osmocom/bsc/gsm_data.h
index e3101ff..bd83ea0 100644
--- a/include/osmocom/bsc/gsm_data.h
+++ b/include/osmocom/bsc/gsm_data.h
@@ -558,7 +558,7 @@
  */
 #define ts_for_each_potential_lchan(lchan, ts) ts_as_pchan_for_each_lchan(lchan, ts, (ts)->pchan_on_init)
 
-enum lchan_activate_mode {
+enum lchan_activate_for {
 	ACTIVATE_FOR_NONE,
 	ACTIVATE_FOR_MS_CHANNEL_REQUEST,
 	ACTIVATE_FOR_ASSIGNMENT,
@@ -567,11 +567,11 @@
 };
 
 extern const struct value_string lchan_activate_mode_names[];
-static inline const char *lchan_activate_mode_name(enum lchan_activate_mode activ_for)
+static inline const char *lchan_activate_mode_name(enum lchan_activate_for activ_for)
 { return get_value_string(lchan_activate_mode_names, activ_for); }
 
 struct lchan_activate_info {
-	enum lchan_activate_mode activ_for;
+	enum lchan_activate_for activ_for;
 	struct gsm_subscriber_connection *for_conn;
 	/* This always is for a specific lchan, so its lchan->type indicates full or half rate.
 	 * When a dyn TS was selected, the lchan->type has been set to the desired rate. */
diff --git a/src/osmo-bsc/lchan_fsm.c b/src/osmo-bsc/lchan_fsm.c
index 8527d38..83524e0 100644
--- a/src/osmo-bsc/lchan_fsm.c
+++ b/src/osmo-bsc/lchan_fsm.c
@@ -70,7 +70,7 @@
 #define lchan_on_activation_failure(lchan, for_conn, activ_for) \
 	_lchan_on_activation_failure(lchan, for_conn, activ_for, \
 				     __FILE__, __LINE__)
-static void _lchan_on_activation_failure(struct gsm_lchan *lchan, enum lchan_activate_mode activ_for,
+static void _lchan_on_activation_failure(struct gsm_lchan *lchan, enum lchan_activate_for activ_for,
 					 struct gsm_subscriber_connection *for_conn,
 					 const char *file, int line)
 {

-- 
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/24301
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Ia4420fcd1234dbee92e768e5a32eab13fba29ea9
Gerrit-Change-Number: 24301
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr at sysmocom.de>
Gerrit-MessageType: newchange
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210519/6cf6fa62/attachment.htm>


More information about the gerrit-log mailing list