Change in osmo-bts[master]: allow to configure multiple oml remote-ip addresses

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

dexter gerrit-no-reply at lists.osmocom.org
Wed Jul 7 14:58:21 UTC 2021


dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/24513 )

Change subject: allow to configure multiple oml remote-ip addresses
......................................................................


Patch Set 9:

(5 comments)

https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c 
File src/common/abis.c:

https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c@150 
PS8, Line 150: 	if (!llist_contains(&bts->bsc_oml_hosts, priv->bsc_oml_host))
> I think I already explained in previous version that imho this is not the proper way of doing this. […]
That makes sense. Thanks.


https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c@170 
PS8, Line 170: 	osmo_get_macaddr(bts_dev_info.mac_addr, "eth0");
> I see  the eth0 comes from old version abis_open() below. […]
Done


https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c@223 
PS8, Line 223: 		.out_state_mask = S(ABIS_LINK_ST_CONNECTING) | S(ABIS_LINK_ST_CONNECTED) | S(ABIS_LINK_ST_FAILED),
> In general I find much more readable to have one state/event per line. […]
Done


https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c@224 
PS8, Line 224: 		.onenter = abis_link_connecting,
> The onenter states are usually named *_onenter to make it clear when they run. […]
Done


https://gerrit.osmocom.org/c/osmo-bts/+/24513/8/src/common/abis.c@432 
PS8, Line 432: 	/* Note: the parameter dst_host is optional and may be NULL. It is
> This comment is outdated
Done



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/24513
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bts
Gerrit-Branch: master
Gerrit-Change-Id: I205f68a3a7f35fee4c38a7cfba2b014237df2727
Gerrit-Change-Number: 24513
Gerrit-PatchSet: 9
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann at sysmocom.de>
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Wed, 07 Jul 2021 14:58:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Comment-In-Reply-To: daniel <dwillmann at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210707/fe02bdbe/attachment.htm>


More information about the gerrit-log mailing list